System requirements

The web site works in all common browsers on desktop. If you are using Internet Explorer, you will need at least version 11 and Windows 10 or newer. Older versions are not supported.

We recommend Google Chrome but there are other options.

Here you can find out what browser you are using. What browser am I using?

The editor tools require at least 1024 px screen width.